
Licensing Agreement

REGISTERED VERSION
One registered copy of Ecopad32 may either be used by a single person who uses the 
software personally on one or more computers, or installed on a single workstation used
non-simultaneously by multiple people, but not both.
You may access the registered version of Ecopad32 through a network, provided that 
you have obtained individual licenses for the software covering all workstations that will 
access the software through the network. For instance, if 8 different workstations will 
access Ecopad32 on the network, each workstation must have its own Ecopad32 
license, regardless of whether they us Ecopad32 at different times or concurrently.

Governing Law:
This agreement shall be governed by the laws of the State of Washington, USA.

DISCLAIMER OF WARRANTY
THIS SOFTWARE AND THE ACCOMPANYING FILES ARE SOLD “AS IS” AND 
WITHOUT WARRANTIES AS TO PERFORMANCE OF MERCHANTABILITY OR ANY 
OTHER WARRANTIES WHETHER EXPRESSED OR IMPLIED.    NO WARRANTY OF 
FITNESS FOR A PARTICULAR PURPOSE IS OFFERED.    ANY LIABILITY OF THE 
SELLER WILL BE LIMITED EXCLUSIVELY TO PRODUCT REPLACEMENT OR 
REFUND OF PURCHASE PRICE.

Shareware License (UNREGISTERED VERSION)
Evaluation & Registration
This is a FREE TRIAL version of the Ecopad32 software. You are hereby licensed to 
use this software for evaluation purposes without charge for a period of 21 days. If you 
use this software after the 21 day evaluation period a registration fee of $26.95 is 
required. Payments must be in US dollars drawn on a US bank, and should be sent to:

Azure D’or Publishing
David T. Ossorio
325 S. Washington Ave. #166
Kent, WA    98032
USA

Unregistered use of Ecopad32 after the 21-day evaluation period is in violation of U.S. 
and international copyright laws.

Distribution
The file “ecpd3241.zip” is freely distributable.

You are hereby licensed to make as many copies of the Shareware version of this 
software (“ecpd3241.zip”) as you wish; give exact copies of the original Shareware 
version (“ecpd3241.zip”) to anyone; and distribute the Shareware version of the 
software and document in its unmodified form via electronic means. There is no charge 



for any of the above.
You are prohibited from charging, or requesting donations, for any such copies, however
made; and from distributing the software and/or documentation with other products 
(commercial or otherwise) without prior permission, with one exception: Disk Vendors 
approved by the Association of Shareware Professionals are permitted to redistribute 
“ecpd3241.zip”, subject to the conditions in this license, without specific written 
permission.



Upgrade Information for Versions 4.x

If you are a registered user of Ecopad32, you can upgrade at no charge, but you will need a new 
registration key.

For a registration key which will be valid for all 4.x versions, do one of the following:

1. E-mail your name (as you want it to appear in the “About” dialog box) and either your mailing address 
or your current registration key to:

davossorio@msn.com

If you have purchased keys for additional names, please include those names also. 

In the subject field, type #upgrade.  Note that in order to process your request we must have either your 
mailing address or current registration key.

You’ll receive a new key by e-mail within 5 business days.

OR, you may:

Send a postcard with your name and address to:

David T. Ossorio
325 S. Washington Ave. #166
Kent, WA    98032
USA



How to order Ecopad32 with a Major Credit Card

See Also:
Why you’ll feel good about ordering

Order with your CompuServe account
Ordering with a check or purchase order
Ordering on the WEB

For technical support or comments about this program, please send e-mail to:
davossorio@msn.com    

When ordering with a credit card, you will receive an instant temporary registration code, which you can 
use to register Ecopad32 until you receive your permanent code. If you provide an e-mail address, your 
permanent code will be e-mailed within 3 business days of the date of your order. If you do not have an e-
mail address, we will mail you an invoice containing your permanent registration code.

For your convenience we have contracted another company, NorthStar Solutions, to process any orders 
you may wish to place with your Visa, MasterCard, or Discover card.    Please be sure to mention you 
would like to order Product # 1861 when placing your order:

For site licenses, use the following product numbers:
Single User License Product #1861 ($26.95)
3 User Site License Product #1862 ($49.95)
10 User Site License Product #1863    ($199.95)
50 User Site License Product #1864 ($399.95)

INTERNET ORDERS
Visit NorthStar Solutions at 
http://www.nstarsolutions.com
and fill out their online order form--fast, easy and secure!

PHONED ORDERS
Calls are taken 10 am - 8 pm, EST, Monday thru Saturday.
1-800-699-6395 (From the U.S. only.) 
1-803-699-6395 

FAXED ORDERS
Available 24 hours.
1-803-699-5465

E-MAILED ORDERS
CompuServe: starmail
America Online: starmail
Internet: starmail@nstarsolutions.com 

MAILED ORDERS
You may purchase Ecopad32 with a check or money order.    
Make your check or money order payable to David T. Ossorio, and mail to:

Azure D’or Publishing
David T. Ossorio
325 S. Washington Ave. #166
Kent, WA    98032



Please provide (or be prepared to provide) the following information: 
* The program you are registering (Product number from above) 
* Your mailing address.
* Your Visa, MasterCard, or Discover # and its expiration date (if using credit card).
* Your drive type if other than 3.5".    
* Your E-Mail address (so NorthStar Solutions can send you an E-Mail confirming your order and 
so we can contact you easily with any important follow-up information, upgrade announcements, 
etc.).



How to order Ecopad32 with a check or company purchase order

To order Ecopad32 with a check or purchase order, simply select “Order Form...” from the Order menu. 

See Also:
Why you’ll feel good about ordering

Ordering with a credit card
Order with your CompuServe account
Ordering on the WEB





What is Shareware?

Shareware distribution gives users a chance to try software before buying it. If you try a Shareware 
program and continue using it, you are expected to register. Individual programs differ on details -- some 
request registration while others require it, some specify a maximum trial period. With registration, you get
anything from the simple right to continue using the software to an updated program with printed manual.

Copyright laws apply to both Shareware and commercial software, and the copyright holder retains all 
rights, with a few specific exceptions as stated below. Shareware authors are accomplished 
programmers, just like commercial authors, and the programs are of comparable quality. (In both cases, 
there are good programs and bad ones!) The main difference is in the method of distribution. The author 
specifically grants the right to copy and distribute the software, either to all and sundry or to a specific 
group.

Shareware is a distribution method, not a type of software. You should find software that suits your needs 
and pocketbook,    whether it's commercial or Shareware. The Shareware system makes fitting your 
needs easier, because you can try before you buy. And because the overhead is low, prices are low also. 
Shareware has the ultimate money-back guarantee -- if you don't use the product, you don't pay for it.



Installing/Uninstalling Ecopad32

Ecopad32 Installation
To install Ecopad32, simply run “ecopad32.exe”

Uninstalling Ecopad32
Ecopad32 can be uninstalled by double clicking on “Add/Remove Programs” in the Win95 or NT 4 Control
Panel



Keyboard Shortcuts

File Menu

New CTRL+N
Open CTRL+O
Save CTRL+S
Print CTRL+P
Print Preview CTRL+SHIFT+P
Print Selection CTRL+E
Save All CTRL+SHIFT+S
Exit ALT+F4

Edit Menu

Undo CTRL+Z
Cut CTRL+X
Copy CTRL+C
Paste CTRL+V
Select All CTRL+A
Delete Line CTRL+Y

Text Menu

Uppercase F11
Lowercase F12

Search Menu

Find CTRL+F
Find Next F3
Replace CTRL+R
Goto Line CTRL+L

Insert Menu

Time CTRL+M
Date CTRL+D
Time/Date F5
Page Break CTRL+SHIFT+K
Filename CTRL+SHIFT+N
File Time/Date CTRL+SHIFT+Q

Options Menu
Printing F7
Fonts F2



Running Ecopad32 From the Command Line

Ecopad32 offers you a number of options when run from the command line. The basic format is:

ecopad32 [options] [filename]

NOTE:
[filename] must be enclosed in quotes if it has spaces.

[options] can be one or more of the following in any order (separated by spaces).    Options not specified 
will default to your last configuration settings. 

Note that the /p2 (print two sided) option is no longer supported. Use /p /2 instead.

/p Prints [filename]
/2 Prints (two sided) [filename].    Must be used with /p

/y1 Set layout to 1x1 (normal)
/y2 Set layout to 1x2
/y3 Set layout to 1x4
/y4 Set layout to 2x2
/y5 Set layout to 2x4
/y6 Set layout to 1x3
/y7 Set layout to 2x1
/b Set layout to booklet printing

/d1 Draw lines
/d2 Draw pages
/e Set page orientation to landscape (portrait is the default)
/a Print using word wrap
/v Convert file from DOS (OEM) to Windows (ANSI) before printing
/zn Set the size of the printing font to n points
/in Set the size of the header/footer font to n points

/h:header Set header text to [header]. NOTE : You must use quotes if the header contains spaces:

Example:
ecopad32 myfile.txt /p “/h:this is the header %F”

/f:footer Set the footer text to [footer].    NOTE: You must use quotes if the footer contains spaces:

Example:
ecopad32    myfile.txt /p “/f:this is the footer %F”

/m:font_name Set the printing font name to [font_name]. NOTE : You must use quotes if the font name
contains spaces:

Example:
ecopad32 myfile.txt /p /m:Arial /z6
[print “myfile” using a 6 point Arial font

/g:config Use printing configuration [config].    
NOTE : You must use quotes if the configuration name contains spaces.
Configuration names are case sensitive.



Example:
ecopad32.exe myfile.txt “/g:my printing configuration”



Product Support

Product support is available at no charge by sending EMail to davossorio@msn.com, or by sending 
postal mail to:

David T. Ossorio
325 S. Washington Ave. #166
Kent, WA    98032
USA

You can also use the above addresses to report any bugs or other problems you have when using 
Ecopad32. Support is available to both registered and non-registered users of Ecopad32. There is no 
time limit on the availability of support.

Your comments and questions about Ecopad32 are always welcome. Thank you for trying Ecopad32!

See Also:
Why you’ll feel good about ordering

Ordering with a credit card
Order with your CompuServe account
Ordering with a check or purchase order
Ordering on the WEB



Booklet Options

Gutter Margins
Gutter margins are the right and left margins on the inside of each booklet page:

The settings you enter here are used only when printing booklets.

Gutter Margin
Ecopad32 uses a single measurement for both the left and right gutter margins.

Unit of Measure
Select inches or centimeters



Benefits of Registration

When you purchase Ecopad32, you will receive a registration key which will convert any 4.x version of 
Ecopad32 into a registered version. You will also receive an invoice in the (postal) mail which will contain 
your registration key. You can always download the latest version of Ecopad32 at:

http://ourworld.compuserve.com/homepages/dave_ossorio/

Additionally, 3% of your total purchase price will be donated to St. Jude Children's 
Research Hospital. St Jude Children's Research Hospital is a non-profit organization 
which is dedicated to treating and finding a cure for many types of childhood cancer. By 
purchasing Ecopad32, you will help over 4,000 children with cancer who are currently 
being treated at St. Jude, and will help the researchers there find more effective ways to
cure childhood cancer. No family is ever charged for treatment at St. Jude. By 
purchasing Ecopad32, you will be helping to make a difference in the lives of thousands
of children with cancer.

See Also:

Ordering with a credit card
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Ordering with a check or purchase order
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Contact Information

Your comments are always appreciated. If you have a question or comment about Ecopad32 (even if you 
are not a registered user), or a feature you would like to see in a future release, I can be reached at the 
following addresses:

David T. Ossorio
325 S. Washington Ave. #166
Kent, WA    98032
USA

Internet E-Mail (much faster):
davossorio@msn.com

See Also:
Why you’ll feel good about ordering

Ordering with a credit card
Order with your CompuServe account
Ordering with a check or purchase order
Ordering on the WEB



How do I print my document as a booklet?

1. Select “Printing” from the “Options” menu
2. Select “booklet” as the page layout option.
3. To print the booklet on one side of the page only, select “Print” from the “File” menu.
4. To print the booklet using both sides of the page, select “Print Odd/Even Pages” from the “File” 
menu.

Tips

· For best results, set the page orientation to “Landscape” 
· You can set the gutter (inside) margins by clicking on the “Booklet” tab



What kinds of documents can I print with Ecopad32?

Ecopad32, like Windows Notepad, is a text editor. This means that Ecopad32 only understands plain text 
(ASCII) and Rich Text Format (rtf) documents. Other kinds of documents created with commercial word 
processors (like Microsoft Word) will not load or print correctly.

Note that when you open an RTF document into Ecopad32, Ecopad32 will extract only the text. 
Any formatting information (such as bold, italic) will be lost.    Thus you should save the document with a 
“.txt” rather than an “rtf” extension, unless you’re editing the rtf codes directly.

Tip
Anything that you can load into Windows Notepad, you can load into Ecopad32.



How large a document can I open?

Ecopad32 can open documents up to 32 megabytes in size.



How do I print with a very small (4 or 5 point) font?

In any Windows application (include Ecopad32), you can specify the point size of any True Type font by 
simply typing the desired point size in the “Size” textbox of the Choose Font Dialog box (the list box will 
only display point sizes as small as 8, so you have to type the size yourself if you want anything smaller).



Booklet Printing
Ecopad32 can now be used to print booklets!

· You can now select “booklet” in the page layout dialog box
· No other configuration is necessary
· Booklets can be printed single or double sided
· You can set the gutter (inside) margins



Configurable Tools

Ecopad32 now supports user configurable tools

· Add your favorite tools (executables) to the “tools” menu
· You can define the menu text for each tool
· You can define the command line arguments for each tool



Printing Configurations

Ecopad32 now lets you save your favorite printer configurations

· Save page layout, printing font, headers/footers, etc. using one name
· Quickly select saved configurations with the “Printing Configurations” combo box



More Tab Options

· You can set printing tabs in inches, centimeters, or characters in the printing font



Multiple Document Interface (MDI)

Ecopad32 now supports the MDI interface

· You can have as many open document windows as system memory allows



Line Numbers

You can now add line numbers to your printed documents

· You can set the starting line number and increment
· Optionally restart line numbers at each page



Page Breaks

Ecopad32 now recognizes the page break character when printing

· You can insert a page break (form feed) directly into the active document



Custom Time Date Formats

You can select from a number of predefined time/date formats, or define your own custom format



Fully Configurable Toolbar

Ecopad32’s toolbar is now fully configurable

· Easily add/remove toolbar buttons



Separate Fonts for Headers/Footers

You can now select separate fonts for printing headers and footers



New Editor Options

Ecopad32 now includes many new options for its editor

· Line & Column, file size information in the status bar
· Blue background/white text
· Each document window has its own status bar, which can display file information
· You can make the mouse pointer disappear when you type (and reappear when you move the 

mouse)



Header/Footer Escapes

Ecopad32 has many new header footer escapes.    
In addition to the escapes available in version 3.x, you can now insert the following information in headers
and footers:

&H Full path of file  
&Z File Size
&A Date file was created
&E Date file was modified
&M Time file was created
&U Time file was modified
&G Total number of pages
&X Current line number



Finding characters or words

To find specific characters or words

1 On the Search menu, click Find. 
2 In the Find What box, type the characters or words you want to find. 
3 Click Find Next. 



To delete, cut, copy, and paste text

· To delete characters to the left of the insertion point, press the BACKSPACE key. 

· To delete characters to the right of the insertion point, press the DELETE key.

· To delete words, select them, and then press the BACKSPACE or DELETE key.

· To cut text so you can move it to another location, select the text. Then, on the Edit menu, click Cut. 

· To copy text so you can paste a copy of it in another location, select the text. Then, on the Edit menu, 
click Copy. 

· To paste text you have cut or copied, place the insertion point where you want to paste the text. Then,
on the Edit menu, click Paste.



To wrap text to the window size

On the Edit menu, click Word Wrap.

Note

· Wrapping text will also affect the way the text looks when printing



To insert the time and date in a document

1 Move the insertion point to where you want to add the time and date.

2 On the Insert menu, click Time/Date.

Tip

You can also insert the following document information (see the Edit menu):

· Filename
· File Time/Date
· Another text file



To keep a log by using Ecopad32

1 On the first line of an Ecopad32 document, type the following at the left margin, making sure you 
include the period:

.LOG 

2 Save the document.

Note

Every time you open this document, Ecopad32 will append the current time and date, as specified
by your computer's clock, to the end of it. 



Booklet Printing

To print your document as a booklet using Ecopad32:

1 Select “Printing” from the Options menu
2 Click “Booklet” in the Page Layout listbox
3 Click the “Landscape” button (recommended if your printer supports landscape printing)
4 Click OK
5 Select “Print” or “Print Two Sided” from the File menu

Notes

· Booklets are always printed as two adjacent pages (equivalent to 1x2 page layout)



Save Printer Configuration Dialog

A printer configuration includes the following:

· Printing tabs
· Page layout, orientation
· Page drawing (lines, boxes)
· Header/Footer text, font, style
· Printing font
· Line number options

You can save all of this information under a single name, which can later be quickly selected for printing.

Name
Enter the name of the printer configuration. The name can contain up to 32 characters, including spaces



Time/Date Format Page (Printing Options Property Sheet)

Date
Select the date format.

Custom date format
If you select “custom” for Date, you can define your own date format here.

Time
Select the time format.



Reformat Text Dialog

Reformat
Click “All text” to reformat the entire document, or “Current selection only”

Convert DOS (OEM) text to Windows (ANSI text)
This option converts DOS text, which uses the OEM character set, to Windows text, which uses the ANSI 
character set. This option is useful if you’re loading a file which was created with a DOS text editor.

Remove CR at the end of lines
Removes carriage returns at the end of each line.

Remove Page Breaks
Removes page breaks from the document.

Tip
After selecting OK, you can undo this formatting by selecting “Undo” from the Edit menu



    General Printing Options Page

Printing Order
If you printer ejects pages in the correct order, select “First page to last”.    If you printer ejects pages in 
reverse order, select “Last page to first”.

Use quick printing for toolbar buttons
If check, the “Print” toolbar buttons will not display the print dialog



Printing Tabs Property Page

You can set printing tabs at inches, centimeters, or characters in the current printing font.

Tip
If you are using a fixed width font, you can get good results with character tabs.    If you’re printing with a 
true type font, you’ll get best results with inches or centimeters.



Advanced Printing Property Page

Compressed page margins in characters
These are special “gutter” margins which affect only the inside margins of compressed pages:

These margins are always measured in character widths (left, right) or heights (top, bottom) of the current
printing font.

Header/Footer

You can set the number of lines (in the current printing font) between the header/footer and the start of 
the document text.



Display Options Property Page

Make the Mouse Pointer Invisible When Typing
When this option is selected, the mouse pointer will disappear when you start typing (making it easier to 
see the screen), and reappear when the mouse is moved.

Always on Top
Select this option to keep the Ecopad32 workspace on top of all other windows.

Open Document Windows Maximized
Select this option to open new document Windows maximized

Blue Background, White Text
Use blue background/white text for all document windows

Default to Word Wrap
When selected, new document windows will always open with word wrap checked (see the Edit menu)

Use Workspace Color
Use color for the workspace background.    You can also select the color used by clicking “Customize…”



File Extensions Property Page

Current file extensions
Lists all of the file extensions which appear in the Files of type selection box in the file “Open” dialog.

Add
Add an extension

Delete
Delete an extension

Always default to *.*
When checked, the file “Open” dialog will default to “*.*” in the Files of type selection box.



General Options Property Page

Number of recent file to show on File menu
You can select between 0 and 8 files for Ecopad32 to remember on the recent file menu

Automatically convert RTF files when loading
If selected, Ecopad32 will extract the text automatically when loading a document with the extension “.rtf”. 
If you want to edit the rtf codes directly, uncheck this option.

Automatically convert DOS text to Windows text
If selected, Ecopad32 will convert DOS text to Windows text automatically when loading a document. 
Useful only if you are working with a large number of DOS text documents.



Document Status Bar Property Page

The document status bar appears at the bottom of each document window you open.
You can check zero or more of these options. The document status bar will disappear if all of the options 
are unchecked.



Tabs Property Page

The tabs you set hear apply only to the display of all documents (you set separate tabs for printing by 
selection Options/Printing… and clicking on the Tabs property page.)

Set tabs every 0 units to use the default value.



Add/Edit Tool Dialog

Menu Text
Displayed on the “Tools” menu

Command
The full path of the executable of the tool (for example, c:\winword.exe)

Arguments
Specifies additional arguments for the tool each time you start it. Several macros are also available:

Macro Name Expands to

$(CurCol) The current cursor column position within the active window.

$(CurDir) The current working directory (defined as drive+path).

$(CurLine) The current cursor line position within the active window.

$(FileExt) The filename extension of the current source.

$(FileName) The filename of the current source (defined as filename); blank if a nonsource window is 
active.

$(FilePath) The complete filename of the current source (defined as drive+path+filename); blank if a 
nonsource window is active.

Example:
To run Word for Windows with the current document, you would use $(FilePath) as the argument.



Headers/Footers Dialog

View
Select either the header or footer

Text
The text of the header or footer.    Click on the right arrow button to insert escapes (page number, etc.)

Lines
You can draw various lines above/below the header or footer.

Font
The font selected here will be used for both the header and the footer.



Page Layout Property Page

NOTE: The settings you enter here affect all documents.

Page Layout
Select the printing compression

Page Orientation
Select Portrait or Landscape

Page Borders
Pages can optionally be separated by lines or boxes

Configuration
Select a printing configuration

Save As
Saves the current settings as a printing configuration

Delete
Deletes a printing configuration



Line Numbers Dialog

Add Line Numbers
Must be checked to enable line numbers

Stating At
Enter the starting line number. Must be larger than 0.

Count By
Displays the line number if it a multiple of this number. Usually this is set to 1.

Number of Digits
The width of the line number field in digits. For documents up to 99,999 lines, this should be set to 5.    
Increase this value to add more space to the line number field along the left margin.

Restart Each Page
Restart numbering each page at the value entered in Starting At 

Show Leading Zero
For numbers smaller than the maximum number of digits, display leading zeros.
Example: line 5 would be displayed as 00005.



Printing Margins Property Page

Set the printing margins here in inches or centimeters. These settings apply to all documents.



Fonts Dialog

Enter the fonts used for screen display and printing.
These selections will apply to all documents opened in Ecopad32.

Tip
· You can select a very small (less than 8 point) printing font by typing in the point size.    The Windows 

printing dialogs do show fonts smaller than 8 points in the listbox, but a small point size can always be
typed in directly.



Customize Tools Dialog

Ecopad32 allows you to add any number of tools (executable programs) to the tools menu.

Menu Items
Displays a list of the currently defined tools

Add
Adds a new tool

Edit
Edit the properties of a currently defined tool

Remove
Removes a tool



File Extension Dialog

The file extensions you enter here will appear in the “Show files of type” list box when you open a 
document in Ecopad32.

File Extension
Enter the three letter file extension. Do not include the period.

Description
Enter a description of the file extension



Two Sided Printing Options

Print Even Numbered Pages First
If your printer ejects pages face up, select this option.

Print Odd Numbered Pages First
If your printer ejects pages face down, select this option.

Side 1
Print Last Page To First
For most printers, regardless of page order, you should select this option

Print First Page To Last
Usually you should never have to select this option

Side 2
Print Last Page To First
If your printer ejects pages in the correct order, select this option

Print First Page To Last
If your printer ejects pages in reverse order, select this option



How to find the latest version of Ecopad32

You can always download the most recent version of Ecopad32 at:

http://ourworld.compuserve.com/homepages/dave_ossorio

Your current registration key will work with all 4.x versions, so there is no need to enter your registration 
key again.

See Also:
Why you’ll feel good about ordering

Ordering with a credit card
Order with your CompuServe account
Ordering with a check or purchase order
Ordering on the WEB



How to order Ecopad32 on CompuServe

You can order Ecopad32 on CompuServe as follows:

1. GO SWREG
2. Select “Register Shareware”
3. Search on the keyword “Ecopad32”

The purchase price will be charged to your regular CompuServe account.

See Also:
Why you’ll feel good about ordering

Ordering with a credit card
Ordering with a check or purchase order
Ordering on the WEB



How to Order Ecopad32 on the WEB

To order Ecopad32 on the web, point your browser to:
http://www.nstarsolutions.com

You can also select “Go to WEB order form” from the Ecopad32’s “Order” menu. This will run your default 
browser with the above address.

See Also:
Why you’ll feel good about ordering

Ordering with a credit card
Order with your CompuServe account
Ordering with a check or purchase order
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